What’s Vulnerable › Vulnerabilities
CVE-2026-40863: PhpSpreadsheet: CPU Denial of Service via Unbounded Row Index in SpreadsheetML XML Reader
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-12 · updated 2026-10-26
- Weakness: CWE-770
Description
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0, the SpreadsheetML XML reader (Reader\Xml) does not validate the ss:Index row attribute against the maximum allowed row count (AddressRange::MAX_ROW = 1,048,576). An attacker can craft a SpreadsheetML XML file with ss:Index="999999999" on a <Row> element, which inflates the internal cachedHighestRow to ~1 billion. Any subsequent call to getRowIterator() without an explicit end row will attempt to iterate ~1 billion rows, causing CPU exhaustion and denial of service. This vulnerability is fixed in 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0.
Affected products
- PHPOffice PhpSpreadsheet: before 1.30.4; from 2.0.0 before 2.1.16; from 2.2.0 before 2.4.5; from 3.3.0 before 3.10.5; from 4.0.0 before 5.7.0 — fixed in 1.30.4, 2.1.16, 2.4.5, 3.10.5, 5.7.0
How to fix
Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.30.4, 2.1.16, 2.4.5, 3.10.5. Check the vendor advisory for mitigations.
References
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-84wq-86v6-x5j6
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-84wq-86v6-x5j6
Get alerted when CVE-2026-40863 or the next vulnerability affects your stack