What’s Vulnerable › Vulnerabilities
CVE-2026-40892: PJSIP: Stack buffer overflow in pjsip_auth_create_digest2()
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-21 · updated 2026-10-26
- Weakness: CWE-121
Description
PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, a stack buffer overflow exists in pjsip_auth_create_digest2() in PJSIP when using pre-computed digest credentials (PJSIP_CRED_DATA_DIGEST). The function copies credential data using cred_info->data.slen as the length without an upper-bound check, which can overflow the fixed-size ha1 stack buffer (128 bytes) if data.slen exceeds the expected digest string length.
Affected products
- Pjsip: before 2.17 — fixed in 2.17
How to fix
Upgrade to a fixed version: Pjsip 2.17. Check the vendor advisory for mitigations.
References
- https://github.com/pjsip/pjproject/commit/c82123ea6f3c3652bbc9ebd5e9e658c301451687
- https://github.com/pjsip/pjproject/security/advisories/GHSA-2wcg-w3c4-48r7
Get alerted when CVE-2026-40892 or the next vulnerability affects your stack