What’s Vulnerable › Vulnerabilities
CVE-2026-40900: DataEase has SQL Injection via Stacked Queries
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-16 · updated 2026-06-17
- Weakness: CWE-89
Description
DataEase is an open-source data visualization and analytics platform. Versions 2.10.20 and below contain a SQL injection vulnerability in the /de2api/datasetData/previewSql endpoint. The user-supplied SQL is wrapped in a subquery without validation that the input is a single SELECT statement. Combined with the JDBC blocklist bypass that allows enabling allowMultiQueries=true, an attacker can break out of the subquery and execute arbitrary stacked SQL statements, including UPDATE and other write operations, against the connected database. An authenticated attacker with access to valid datasource credentials can achieve full read and write access to the underlying database. This issue has been fixed in version 2.10.21.
Affected products
- dataease: before 2.10.21 — fixed in 2.10.21
How to fix
Upgrade to a fixed version: dataease 2.10.21. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/releases/tag/v2.10.21
- https://github.com/dataease/dataease/security/advisories/GHSA-vqxf-84ph-j3vx
- https://github.com/dataease/dataease/security/advisories/GHSA-vqxf-84ph-j3vx
Get alerted when CVE-2026-40900 or the next vulnerability affects your stack