What’s Vulnerable › Vulnerabilities
CVE-2026-40933: Flowise: Authenticated RCE Via MCP Adapters
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-21 · updated 2026-10-26
- Weakness: CWE-78
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, due to unsafe serialization of stdio commands in the MCP adapter, an authenticated attacker can add an MCP stdio server with an arbitrary command, achieving command execution. The vulnerability lies in a bug in the input sanitization from the “Custom MCP” configuration in http://localhost:3000/canvas - where any user can add a new MCP, when doing so - adding a new MCP using stdio, the user can add any command, even though your code have input sanitization checks such as validateCommandInjection and validateArgsForLocalFileAccess, and a list of predefined specific safe commands - these commands, for example "npx" can be combined with code execution arguments ("-c touch /tmp/pwn") that enable direct code execution on the underlying OS. This vulnerability is fixed in 3.1.0.
Affected products
- FlowiseAI Flowise: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-c9gw-hvqq-f33r
- https://www.ox.security/blog/mcp-supply-chain-advisory-rce-vulnerabilities-across-the-ai-ecosystem
- https://www.ox.security/blog/the-mother-of-all-ai-supply-chains-critical-systemic-vulnerability-at-the-core-of-the-mcp
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-c9gw-hvqq-f33r
Get alerted when CVE-2026-40933 or the next vulnerability affects your stack