What’s Vulnerable › Vulnerabilities
CVE-2026-40944: Oxia: TLS CA certificate chain validation fails with multi-certificate PEM bundles
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-21 · updated 2026-06-17
- Weakness: CWE-295
Description
Oxia is a metadata store and coordination system. Prior to 0.16.2, the trustedCertPool() function in the TLS configuration only parses the first PEM block from CA certificate files. When a CA bundle contains multiple certificates (e.g., intermediate + root CA), only the first certificate is loaded. This silently breaks certificate chain validation for mTLS. This vulnerability is fixed in 0.16.2.
Affected products
- oxia-db oxia: before 0.16.2
References
Get alerted when CVE-2026-40944 or the next vulnerability affects your stack