What’s Vulnerable › Vulnerabilities
CVE-2026-40959
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-16 · updated 2026-06-17
- Weakness: CWE-829
Description
Luanti 5 before 5.15.2, when LuaJIT is used, allows a Lua sandbox escape via a crafted mod.
Affected products
- Luanti: from 5.0.0 before 5.15.2 — fixed in 5.15.2
How to fix
Upgrade to a fixed version: Luanti 5.15.2. Check the vendor advisory for mitigations.
References
- https://github.com/luanti-org/luanti/commit/53cef183e2a85a4daff84ac1a9a7946f940da8f8
- https://github.com/luanti-org/luanti/commit/8a929dfb97aa08337f49ba1bb96a56d6557dc896
- https://github.com/luanti-org/luanti/security/advisories/GHSA-g596-mf82-w8c3
Get alerted when CVE-2026-40959 or the next vulnerability affects your stack