What’s Vulnerable › Vulnerabilities
CVE-2026-40960
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-16 · updated 2026-06-17
- Weakness: CWE-670
Description
Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.
Affected products
- Luanti: from 5.0.0 before 5.15.2 — fixed in 5.15.2
How to fix
Upgrade to a fixed version: Luanti 5.15.2. Check the vendor advisory for mitigations.
References
- https://github.com/luanti-org/luanti/commit/0faf529bc4b89e70a275ed1162047815118f2413
- https://github.com/luanti-org/luanti/commit/827fd4cf7f989482b2dad381fa4afd642ea73e8c
- https://github.com/luanti-org/luanti/security/advisories/GHSA-22c4-238c-m5j4
Get alerted when CVE-2026-40960 or the next vulnerability affects your stack