What’s Vulnerable › Vulnerabilities
CVE-2026-40976
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-27 · updated 2026-07-24
- Weakness: CWE-862
Description
In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints. For an application to be vulnerable, it must: be a servlet-based web application; have no Spring Security configuration of its own and rely on the default web security filter chain; depend on spring-boot-actuator-autoconfigure; not depend on spring-boot-health. If any of the above does not apply, the application is not vulnerable. Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.
Affected products
- Spring Boot: from 4.0.0 before 4.0.6 — fixed in 4.0.6
- Spring Boot: from 4.0.0 before 4.0.6 — fixed in 4.0.6
How to fix
Upgrade to a fixed version: Spring Boot 4.0.6; Spring Boot 4.0.6. Check the vendor advisory for mitigations.
References
- https://spring.io/security/cve-2026-40976
- https://access.redhat.com/security/cve/CVE-2026-40976
- https://bugzilla.redhat.com/show_bug.cgi?id=2463322
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40976.json
Get alerted when CVE-2026-40976 or the next vulnerability affects your stack