What’s Vulnerable › Vulnerabilities
CVE-2026-40982
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-07 · updated 2026-10-26
- Weakness: CWE-22
Description
Spring Cloud Config allows applications to serve arbitrary text and binary files through the spring-cloud-config-server module. A malicious user, or attacker, can send a request using a specially crafted URL that can lead to a directory traversal attack. Spring Cloud Config 3.1.x: affected from 3.1.0 through 3.1.13 (inclusive); upgrade to 3.1.14 or greater (Enterprise Support Only). Spring Cloud Config 4.1.x: affected from 4.1.0 through 4.1.9 (inclusive); upgrade to 4.1.10 or greater (Enterprise Support Only). Spring Cloud Config 4.2.x: affected from 4.2.0 through 4.2.6 (inclusive); upgrade to 4.2.7 or greater (Enterprise Support Only). Spring Cloud Config 4.3.x: affected from 4.3.0 through 4.3.2 (inclusive); upgrade to 4.3.3 or greater. Spring Cloud Config 5.0.x: affected from 5.0.0 through 5.0.2 (inclusive); upgrade to 5.0.3 or greater.
Affected products
- Spring Cloud Config: from 3.1.0 before 3.1.14; from 4.1.0 before 4.1.10; from 4.2.0 before 4.2.7; from 4.3.0 before 4.3.3; from 5.0.0 before 5.0.3 — fixed in 3.1.14, 4.1.10, 4.2.7, 4.3.3, 5.0.3
- Spring Cloud Config: from 3.1.0 before 3.1.14; from 4.1.0 before 4.1.10; from 4.2.0 before 4.2.7; from 4.3.0 before 4.3.3; from 5.0.0 before 5.0.3 — fixed in 3.1.14, 4.1.10, 4.2.7, 4.3.3, 5.0.3
How to fix
Upgrade to a fixed version: Spring Cloud Config 3.1.14, 4.1.10, 4.2.7, 4.3.3; Spring Cloud Config 3.1.14, 4.1.10, 4.2.7, 4.3.3. Check the vendor advisory for mitigations.
References
- https://spring.io/security/cve-2026-40982
- https://access.redhat.com/security/cve/CVE-2026-40982
- https://bugzilla.redhat.com/show_bug.cgi?id=2467619
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40982.json
Get alerted when CVE-2026-40982 or the next vulnerability affects your stack