What’s Vulnerable › Vulnerabilities

CVE-2026-40984: Micrometer HTTP server instrumentations DoS vulnerability

Description

In Micrometer, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Affected versions: micrometer-core 1.16.0 through 1.16.5; 1.15.0 through 1.15.11; 1.14.0 through 1.14.15; 1.13.0 through 1.13.18; 1.9.0 through 1.9.17. micrometer-jetty11 1.16.0 through 1.16.5; 1.15.0 through 1.15.11; 1.14.0 through 1.14.15; 1.13.0 through 1.13.18. micrometer-jetty12 1.16.0 through 1.16.5; 1.15.0 through 1.15.11; 1.14.0 through 1.14.15; 1.13.0 through 1.13.18.

Affected products

How to fix

Upgrade to a fixed version: Spring Micrometer 1.13.19, 1.14.15.1, 1.14.16, 1.15.11.. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-40984 or the next vulnerability affects your stack