What’s Vulnerable › Vulnerabilities

CVE-2026-40985: Data Binding Vulnerability in Spring Web Flow with Unified EL Parser

Description

Applications that configure the WebFlowELExpressionParser are vulnerable to the use of malicious Unified EL expressions. Affected versions: Spring Web Flow 4.0.0; 3.0.0 through 3.0.1; 2.5.0 through 2.5.1.

Affected products

How to fix

Upgrade to a fixed version: Spring Web Flow 2.5.2, 3.0.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-40985 or the next vulnerability affects your stack