What’s Vulnerable › Vulnerabilities

CVE-2026-40988: Unbounded DEFLATE Inflation in SAML 2.0 Service Provider

Description

An application using spring-security-saml2-service-provider and the REDIRECT binding for SAML 2.0 Login or Logout may be vulnerable to a denial of service by way of an unbounded writer that inflates the compressed SAML payload into memory. Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.

Affected products

How to fix

Upgrade to a fixed version: Spring Security 5.7.24, 5.8.26, 6.3.17, 6.4.17; Spring Security 5.7.24, 5.8.26, 6.3.17, 6.4.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-40988 or the next vulnerability affects your stack