What’s Vulnerable › Vulnerabilities
CVE-2026-40994: Wss4jSecurityInterceptor disables WS-I BSP validation by default
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-09-04
- Weakness: CWE-1188
Description
Wss4jSecurityInterceptor initialized its BSP (WS-I Basic Security Profile) compliance flag so that inbound validation disabled WSS4J BSP enforcement on RequestData. Services that validate WS-Security on the network could therefore accept messages that violate BSP rules, weakening protocol-level checks. Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.
Affected products
- Spring Web Services: before 3.1.9; from 4.0.0 before 4.0.19; from 4.1.0 before 4.1.3.1; from 5.0.0 before 5.0.1.1 — fixed in 3.1.9, 4.0.19, 4.1.3.1, 5.0.1.1
How to fix
Upgrade to a fixed version: Spring Web Services 3.1.9, 4.0.19, 4.1.3.1, 5.0.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-40994 or the next vulnerability affects your stack