What’s Vulnerable › Vulnerabilities
CVE-2026-40996: Inbound WS-Security allows RSA PKCS#1 v1.5 key transport by default
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-09-04
- Weakness: CWE-327
Description
Wss4jSecurityInterceptor defaulted allowRSA15KeyTransportAlgorithm to true, overriding Apache WSS4J's safer default for validation RequestData. Inbound WS-Security decryption could therefore accept RSA PKCS#1 v1.5 (rsa-1_5) encrypted key material unless operators explicitly reconfigured the flag. Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.
Affected products
- Spring Web Services: before 3.1.9; from 4.0.0 before 4.0.19; from 4.1.0 before 4.1.3.1; from 5.0.0 before 5.0.1.1 — fixed in 3.1.9, 4.0.19, 4.1.3.1, 5.0.1.1
How to fix
Upgrade to a fixed version: Spring Web Services 3.1.9, 4.0.19, 4.1.3.1, 5.0.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-40996 or the next vulnerability affects your stack