What’s Vulnerable › Vulnerabilities
CVE-2026-40997: SOAP security faults leak Spring Security account state
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-09-04
- Weakness: CWE-209
Description
Several Spring WS integration paths with Spring Security could surface detailed account state (for example locked or disabled user semantics) to remote SOAP clients through exception messages or callback outcomes, instead of failing with generic authentication errors. That behavior assists remote attackers in distinguishing valid accounts from invalid ones and inferring lifecycle state. Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.
Affected products
- Spring Web Services: before 3.1.9; from 4.0.0 before 4.0.19; from 4.1.0 before 4.1.3.1; from 5.0.0 before 5.0.1.1 — fixed in 3.1.9, 4.0.19, 4.1.3.1, 5.0.1.1
How to fix
Upgrade to a fixed version: Spring Web Services 3.1.9, 4.0.19, 4.1.3.1, 5.0.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-40997 or the next vulnerability affects your stack