What’s Vulnerable › Vulnerabilities

CVE-2026-41003: Unencoded HTML Outputs in Spring Security May Allow Cross-Site Scripting

Description

An attacker able to influence values in RelyingPartyRegistration may be able to run arbitrary code on HTML forms generated by Spring Security filters. Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.

Affected products

How to fix

Upgrade to a fixed version: Spring Security 5.7.24, 5.8.26, 6.3.17, 6.4.17; Spring Security 5.7.24, 5.8.26, 6.3.17, 6.4.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41003 or the next vulnerability affects your stack