What’s Vulnerable › Vulnerabilities
CVE-2026-4103: Cross-Site Scripting via HTML Sanitization in WSO2 Publisher and Developer Portals Allows Malicious Script Execution
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-14 · updated 2026-09-18
- Weakness: CWE-79
Description
Insufficient HTML sanitization in the Publisher Portal and Developer Portal allows untrusted user input to be rendered without proper encoding or neutralization. This enables the injection and execution of malicious JavaScript when affected API documents are viewed. Successful exploitation may result in the execution of malicious scripts within the user's browser context when viewing API documentation. Users with permissions to access the API documentation through these portals may be impacted, potentially allowing attackers to perform actions on behalf of the user, depending on their session privileges.
Affected products
- WSO2 API Manager: from 3.2.0 before 3.2.0.470; from 3.2.1 before 3.2.1.89; from 4.1.0 before 4.1.0.254; from 4.2.0 before 4.2.0.194; from 4.3.0 before 4.3.0.105; from 4.4.0 before 4.4.0.69 — fixed in 3.2.0.470, 3.2.1.89, 4.1.0.254, 4.2.0.194, 4.3.0.105, 4.4.0.69
- WSO2 API Control Plane: from 4.5.0 before 4.5.0.55; from 4.6.0 before 4.6.0.19 — fixed in 4.5.0.55, 4.6.0.19
How to fix
Upgrade to a fixed version: WSO2 API Manager 3.2.0.470, 3.2.1.89, 4.1.0.254, 4.2.0.194; WSO2 API Control Plane 4.5.0.55, 4.6.0.19. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-4103 or the next vulnerability affects your stack