What’s Vulnerable › Vulnerabilities

CVE-2026-41043: Apache ActiveMQ, Apache ActiveMQ Web: ActiveMQ Web Console - XSS vulnerability when browsing queues

Description

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field. This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache ActiveMQ 5.19.6, 6.2.5; Apache Activemq Web 5.19.6, 6.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41043 or the next vulnerability affects your stack