What’s Vulnerable › Vulnerabilities
CVE-2026-41080
- Severity: low (CVSS 2.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-16 · updated 2026-07-14
- Weakness: CWE-331
Description
libexpat before 2.8.0 uses insufficient entropy, and thus hash flooding can occur via a crafted XML document.
Affected products
- libexpat project libexpat: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: libexpat project libexpat 2.8.0. Check the vendor advisory for mitigations.
References
- https://blog.hartwork.org/posts/expat-2-8-0-released/
- https://github.com/libexpat/libexpat/issues/47
- https://github.com/libexpat/libexpat/pull/1183
- https://www.openwall.com/lists/oss-security/2026/04/26/1
- http://www.openwall.com/lists/oss-security/2026/04/26/1
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
Get alerted when CVE-2026-41080 or the next vulnerability affects your stack