What’s Vulnerable › Vulnerabilities
CVE-2026-41082
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-16 · updated 2026-10-26
- Weakness: CWE-24
Description
In OCaml opam before 2.5.1, a .install field containing a destination filepath can use ../ to reach a parent directory.
Affected products
- Debian Linux: 11.0
- OCaml opam: before 2.5.1 — fixed in 2.5.1
- Red Hat Enterprise Linux: 10.0
How to fix
Upgrade to a fixed version: OCaml opam 2.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/ocaml/opam/pull/6897
- https://github.com/ocaml/opam/releases/tag/2.5.1
- https://osv.dev/vulnerability/OSEC-2026-03
- https://lists.debian.org/debian-lts-announce/2026/04/msg00021.html
- https://access.redhat.com/security/cve/CVE-2026-41082
- https://bugzilla.redhat.com/show_bug.cgi?id=2459003
- https://osv.dev/vulnerability/OSEC-2026-03
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41082.json
Get alerted when CVE-2026-41082 or the next vulnerability affects your stack