What’s Vulnerable › Vulnerabilities
CVE-2026-41131: OpenFGA has Improper Policy Enforcement
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-06-17
- Weakness: CWE-706
Description
OpenFGA is an authorization/permission engine built for developers. Prior to version 1.14.1, in specific scenarios, models using conditions with caching enabled can result in two different check requests producing the same cache key. This could result in OpenFGA reusing an earlier cached result for a subsequent request. The preconditions for vulnerability are the model having relations which rely on condition evaluation and the user having caching enabled. OpenFGA v1.14.1 contains a fix.
Affected products
- openfga Helm Charts: before 0.3.1 — fixed in 0.3.1
- openfga: before 1.14.1 — fixed in 1.14.1
How to fix
Upgrade to a fixed version: openfga Helm Charts 0.3.1; openfga 1.14.1. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/releases/tag/v1.14.1
- https://github.com/openfga/openfga/security/advisories/GHSA-57j5-qwp2-vqp6
Get alerted when CVE-2026-41131 or the next vulnerability affects your stack