What’s Vulnerable › Vulnerabilities
CVE-2026-41137: Flowise: Code Injection in CSVAgent leads to Authenticated RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-23 · updated 2026-10-26
- Weakness: CWE-94
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, The CSVAgent allows providing a custom Pandas CSV read code. Due to lack of sanitization, an attacker can provide a command injection payload that will get interpolated and executed by the server. This vulnerability is fixed in 3.1.0.
Affected products
- FlowiseAI Flowise: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9wc7-mj3f-74xv
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9wc7-mj3f-74xv
Get alerted when CVE-2026-41137 or the next vulnerability affects your stack