What’s Vulnerable › Vulnerabilities

CVE-2026-41142: OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API

Description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From versions 3.0.0 to before 3.2.9, 3.3.0 to before 3.3.11, and 3.4.0 to before 3.4.11, there is an integer overflow in ImageChannel::resize that leads to heap OOB write via OpenEXRUtil public API. This issue has been patched in versions 3.2.9, 3.3.11, and 3.4.11.

Affected products

How to fix

Upgrade to a fixed version: AcademySoftwareFoundation openexr 3.2.9, 3.3.11, 3.4.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41142 or the next vulnerability affects your stack