What’s Vulnerable › Vulnerabilities
CVE-2026-41159: Mermaid: Improper sanitization of configuration leads to CSS injection
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-29 · updated 2026-07-21
- Weakness: CWE-94
Description
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.6 and 11.15.0, Mermaid's default configuration allows injecting CSS that applies outside of the Mermaid diagram via the fontFamily, themeCSS, and altFontFamily configuration options. The injected CSS exploits stylis's & (scope reference) handling. :not(&) escapes the #mermaid-xxx automatic scoping, applying styles to all page elements. Global at-rules (@font-face, @keyframes, @counter-style) are also injectable as stylis hoists them to top level. This allows page defacement and DOM attribute exfiltration via CSS :has() selectors. This vulnerability is fixed in 10.9.6 and 11.15.0.
Affected products
- mermaid-js mermaid: before 10.9.6; from 11.0.0 before 11.15.0 — fixed in 10.9.6, 11.15.0
How to fix
Upgrade to a fixed version: mermaid-js mermaid 10.9.6, 11.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/mermaid-js/mermaid/commit/64769738d5b59211e1decb471ffbaca8afec51aa
- https://github.com/mermaid-js/mermaid/commit/a9d9f0d8eb790349121508688cd338253fd80d76
- https://github.com/mermaid-js/mermaid/releases/tag/mermaid@11.15.0
- https://github.com/mermaid-js/mermaid/releases/tag/v10.9.6
- https://github.com/mermaid-js/mermaid/security/advisories/GHSA-87f9-hvmw-gh4p
Get alerted when CVE-2026-41159 or the next vulnerability affects your stack