What’s Vulnerable › Vulnerabilities
CVE-2026-41163: bubblewrap vulnerable to privilege escalation in setuid mode via ptrace
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-09 · updated 2026-08-24
- Weakness: CWE-269
Description
bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.
Affected products
- containers bubblewrap: from 0.11.0, < 0.11.2
References
- https://github.com/containers/bubblewrap/releases/tag/v0.11.2
- https://github.com/containers/bubblewrap/security/advisories/GHSA-xq78-7hw4-5jvp
- https://access.redhat.com/security/cve/CVE-2026-41163
- https://bugzilla.redhat.com/show_bug.cgi?id=2468439
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41163.json
Get alerted when CVE-2026-41163 or the next vulnerability affects your stack