What’s Vulnerable › Vulnerabilities
CVE-2026-41166: OpenRemote has Improper Access Control via updateUserRealmRoles function
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-22 · updated 2026-06-17
- Weakness: CWE-284
Description
OpenRemote is an open-source internet-of-things platform. Prior to version 1.22.1, a user who has `write:admin` in one Keycloak realm can call the Manager API to update Keycloak realm roles for users in another realm, including `master`. The handler uses the `{realm}` path segment when talking to the identity provider but does not check that the caller may administer that realm. This could result in a privilege escalation to `master` realm administrator if the attacker controls any user in `master` realm. Version 1.22.1 fixes the issue.
Affected products
- openremote: before 1.22.1 — fixed in 1.22.1
How to fix
Upgrade to a fixed version: openremote 1.22.1. Check the vendor advisory for mitigations.
References
- https://github.com/openremote/openremote/releases/tag/1.22.1
- https://github.com/openremote/openremote/security/advisories/GHSA-49vv-25qx-mg44
- https://github.com/openremote/openremote/security/advisories/GHSA-49vv-25qx-mg44
Get alerted when CVE-2026-41166 or the next vulnerability affects your stack