What’s Vulnerable › Vulnerabilities
CVE-2026-41206: PySpector has a Plugin Code Execution Bypass via Incomplete Static Analysis in PluginSecurity.validate_plugin_code
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-23 · updated 2026-10-26
- Weakness: CWE-184
Description
PySpector is a static analysis security testing (SAST) Framework engineered for modern Python development workflows. The plugin security validator in PySpector uses AST-based static analysis to prevent dangerous code from being loaded as plugins. Prior to version 0.1.8, the blocklist implemented in `PluginSecurity.validate_plugin_code` is incomplete and can be bypassed using several Python constructs that are not checked. An attacker who can supply a plugin file can achieve arbitrary code execution within the PySpector process when that plugin is installed and executed. Version 0.1.8 fixes the issue.
Affected products
- ParzivalHack PySpector: before 0.1.8 — fixed in 0.1.8
How to fix
Upgrade to a fixed version: ParzivalHack PySpector 0.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/ParzivalHack/PySpector/commit/3c9547157fc07396f22b26b3484a9a91eba98555
- https://github.com/ParzivalHack/PySpector/commit/4e279e078c53d760fd321ff9b698d683c65ccb8e
- https://github.com/ParzivalHack/PySpector/security/advisories/GHSA-vp22-38m5-r39r
- https://github.com/ParzivalHack/PySpector/security/advisories/GHSA-vp22-38m5-r39r
Get alerted when CVE-2026-41206 or the next vulnerability affects your stack