What’s Vulnerable › Vulnerabilities
CVE-2026-41229: Froxlor has a PHP Code Injection via Unescaped Single Quotes in userdata.inc.php Generation (MysqlServer API)
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-23 · updated 2026-06-17
- Weakness: CWE-94
Description
Froxlor is open source server administration software. Prior to version 2.3.6, `PhpHelper::parseArrayToString()` writes string values into single-quoted PHP string literals without escaping single quotes. When an admin with `change_serversettings` permission adds or updates a MySQL server via the API, the `privileged_user` parameter (which has no input validation) is written unescaped into `lib/userdata.inc.php`. Since this file is `require`d on every request via `Database::getDB()`, an attacker can inject arbitrary PHP code that executes as the web server user on every subsequent page load. Version 2.3.6 contains a patch.
Affected products
- froxlor: before 2.3.6 — fixed in 2.3.6
How to fix
Upgrade to a fixed version: froxlor 2.3.6. Check the vendor advisory for mitigations.
References
- https://github.com/froxlor/froxlor/commit/3589ddf93ab59eb2a8971f0f56cbf6266d03c4ae
- https://github.com/froxlor/froxlor/releases/tag/2.3.6
- https://github.com/froxlor/froxlor/security/advisories/GHSA-gc9w-cc93-rjv8
- https://github.com/froxlor/froxlor/security/advisories/GHSA-gc9w-cc93-rjv8
Get alerted when CVE-2026-41229 or the next vulnerability affects your stack