What’s Vulnerable › Vulnerabilities
CVE-2026-41265: Flowise: Airtable_Agent Code Injection Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-23 · updated 2026-10-26
- Weakness: CWE-77
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the specific flaw exists within the run method of the Airtable_Agents class. The issue results from the lack of proper sandboxing when evaluating an LLM generated python script. Using prompt injection techniques, an unauthenticated attacker with the ability to send prompts to a chatflow using the Airtable Agent node may convince an LLM to respond with a malicious python script that executes attacker controlled commands on the flowise server. This vulnerability is fixed in 3.1.0.
Affected products
- FlowiseAI Flowise: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-v38x-c887-992f
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-v38x-c887-992f
Get alerted when CVE-2026-41265 or the next vulnerability affects your stack