What’s Vulnerable › Vulnerabilities
CVE-2026-41268: Flowise: Flowise Parameter Override Bypass Remote Command Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-23 · updated 2026-10-26
- Weakness: CWE-20
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.
Affected products
- FlowiseAI Flowise: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-cvrr-qhgw-2mm6
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-cvrr-qhgw-2mm6
Get alerted when CVE-2026-41268 or the next vulnerability affects your stack