What’s Vulnerable › Vulnerabilities
CVE-2026-41282
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-20 · updated 2026-10-26
- Weakness: CWE-94
Description
ProjectDiscovery Nuclei 3 before 3.8.0 allows DSL expression injection. This affects use of -env-vars for multi-step templates against untrusted targets (not the default configuration).
Affected products
- projectdiscovery nuclei: from 3.0.0 before 3.8.0 — fixed in 3.8.0
How to fix
Upgrade to a fixed version: projectdiscovery nuclei 3.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/projectdiscovery/nuclei/commit/6c803c74d193f85f8a6d9803ce493fd302cad0eb
- https://github.com/projectdiscovery/nuclei/commit/d2217320162d5782ca7cb95bef9dda17063818f3
- https://github.com/projectdiscovery/nuclei/pull/7221
- https://github.com/projectdiscovery/nuclei/pull/7321
- https://github.com/projectdiscovery/nuclei/security/advisories/GHSA-jm34-66cf-qpvr
- https://github.com/projectdiscovery/nuclei/pull/7221
- https://github.com/projectdiscovery/nuclei/pull/7321
Get alerted when CVE-2026-41282 or the next vulnerability affects your stack