What’s Vulnerable › Vulnerabilities
CVE-2026-41294: OpenClaw < 2026.3.28 - Environment Variable Injection via CWD .env File
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-21 · updated 2026-06-17
- Weakness: CWE-15
Description
OpenClaw before 2026.3.28 loads the current working directory .env file before trusted state-dir configuration, allowing environment variable injection. Attackers can place a malicious .env file in a repository or workspace to override runtime configuration and security-sensitive environment settings during OpenClaw startup.
Affected products
- OpenClaw: before 2026.3.28 — fixed in 2026.3.28
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.28. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-8rh7-6779-cjqq
- https://www.vulncheck.com/advisories/openclaw-environment-variable-injection-via-cwd-env-file
Get alerted when CVE-2026-41294 or the next vulnerability affects your stack