What’s Vulnerable › Vulnerabilities
CVE-2026-41302: OpenClaw < 2026.3.31 - Server-Side Request Forgery via Unguarded fetch() in Marketplace Plugin Download
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-21 · updated 2026-06-17
- Weakness: CWE-918
Description
OpenClaw before 2026.3.31 contains a server-side request forgery vulnerability in the marketplace plugin download functionality that allows remote attackers to make arbitrary network requests. Attackers can exploit unguarded fetch() calls to access internal resources or interact with external services on behalf of the affected system.
Affected products
- OpenClaw: before 2026.3.31 — fixed in 2026.3.31
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.31. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/8deb9522f3d2680820588b190adb4a2a52f3670b
- https://github.com/openclaw/openclaw/security/advisories/GHSA-9q7v-8mr7-g23p
- https://www.vulncheck.com/advisories/openclaw-server-side-request-forgery-via-unguarded-fetch-in-marketplace-plugin-download
Get alerted when CVE-2026-41302 or the next vulnerability affects your stack