What’s Vulnerable › Vulnerabilities
CVE-2026-41324: basic-ftp vulnerable to denial of service via unbounded memory consumption in Client.list()
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-24 · updated 2026-10-26
- Weakness: CWE-400
Description
basic-ftp is an FTP client for Node.js. Versions prior to 5.3.0 are vulnerable to denial of service through unbounded memory growth while processing directory listings from a remote FTP server. A malicious or compromised server can send an extremely large or never-ending listing response to `Client.list()`, causing the client process to consume memory until it becomes unstable or crashes. Version 5.3.0 fixes the issue.
Affected products
- patrickjuchli basic-ftp: before 5.3.0 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: patrickjuchli basic-ftp 5.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/patrickjuchli/basic-ftp/security/advisories/GHSA-rp42-5vxx-qpwr
- https://github.com/patrickjuchli/basic-ftp/security/advisories/GHSA-rp42-5vxx-qpwr
Get alerted when CVE-2026-41324 or the next vulnerability affects your stack