What’s Vulnerable › Vulnerabilities
CVE-2026-41330: OpenClaw < 2026.3.31 - Environment Variable Override via Host Exec Policy
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-21 · updated 2026-06-17
- Weakness: CWE-453
Description
OpenClaw before 2026.3.31 contains an environment variable override vulnerability in host exec policy that fails to properly enforce proxy, TLS, Docker, and Git TLS controls. Attackers can bypass security controls by overriding environment variables to circumvent proxy settings, TLS verification, Docker restrictions, and Git TLS enforcement.
Affected products
- OpenClaw: before 2026.3.31 — fixed in 2026.3.31
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.31. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/4d912e04519b4bd53b248437c53748cdebce9a41
- https://github.com/openclaw/openclaw/security/advisories/GHSA-9gp8-hjxr-6f34
- https://www.vulncheck.com/advisories/openclaw-environment-variable-override-via-host-exec-policy
Get alerted when CVE-2026-41330 or the next vulnerability affects your stack