What’s Vulnerable › Vulnerabilities
CVE-2026-41336: OpenClaw < 2026.3.31 - Arbitrary Hook Code Execution via OPENCLAW_BUNDLED_HOOKS_DIR Environment Variable Override
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-23 · updated 2026-06-17
- Weakness: CWE-829
Description
OpenClaw before 2026.3.31 allows workspace .env files to override the OPENCLAW_BUNDLED_HOOKS_DIR environment variable, enabling loading of attacker-controlled hook code. Attackers can replace trusted default-on bundled hooks from untrusted workspaces to execute arbitrary code.
Affected products
- OpenClaw: before 2026.3.31 — fixed in 2026.3.31
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.31. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/330a9f98cb29c79b1c16a2117e03d6276a0d6289
- https://github.com/openclaw/openclaw/security/advisories/GHSA-3qpv-xf3v-mm45
- https://www.vulncheck.com/advisories/openclaw-arbitrary-hook-code-execution-via-openclaw-bundled-hooks-dir-environment-variable-override
Get alerted when CVE-2026-41336 or the next vulnerability affects your stack