What’s Vulnerable › Vulnerabilities
CVE-2026-41344: OpenClaw < 2026.3.28 - Privilege Escalation via chat.send /verbose Parameter
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-23 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw before 2026.3.28 contains a privilege escalation vulnerability in the chat.send endpoint that allows write-scoped gateway callers to persist admin-only verboseLevel session overrides. Attackers can exploit the /verbose parameter to bypass access controls and expose sensitive reasoning or tool output intended to be restricted to administrators.
Affected products
- OpenClaw: before 2026.3.28 — fixed in 2026.3.28
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.28. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-5h2w-qmfp-ggp6
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-chat-send-verbose-parameter
Get alerted when CVE-2026-41344 or the next vulnerability affects your stack