What’s Vulnerable › Vulnerabilities
CVE-2026-41352: OpenClaw < 2026.3.31 - Remote Code Execution via Node Scope Gate Bypass
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-23 · updated 2026-06-17
- Weakness: CWE-862
Description
OpenClaw before 2026.3.31 contains a remote code execution vulnerability where a device-paired node can bypass the node scope gate authentication mechanism. Attackers with device pairing credentials can execute arbitrary node commands on the host system without proper node pairing validation.
Affected products
- OpenClaw: before 2026.3.31 — fixed in 2026.3.31
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.31. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/3886b65ef21d02808c1a106fa1f9f69e22f71c32
- https://github.com/openclaw/openclaw/security/advisories/GHSA-xj9w-5r6q-x6v4
- https://www.vulncheck.com/advisories/openclaw-remote-code-execution-via-node-scope-gate-bypass
Get alerted when CVE-2026-41352 or the next vulnerability affects your stack