What’s Vulnerable › Vulnerabilities
CVE-2026-41371: OpenClaw < 2026.3.28 - Privilege Escalation via chat.send Reset Command
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-28 · updated 2026-07-24
- Weakness: CWE-863
Description
OpenClaw before 2026.3.28 contains a privilege escalation vulnerability in chat.send that allows write-scoped gateway callers to trigger admin-only session reset operations. Attackers can rotate target sessions, archive prior transcript state, and force new session IDs without requiring admin scope by exploiting improper authorization checks in the chat.send path.
Affected products
- OpenClaw: before 2026.3.28 — fixed in 2026.3.28
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.28. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-5r8f-96gm-5j6g
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-chat-send-reset-command
Get alerted when CVE-2026-41371 or the next vulnerability affects your stack