What’s Vulnerable › Vulnerabilities
CVE-2026-41377: OpenClaw < 2026.3.31 - Fail-Open Security Scan Bypass in Plugin Installation
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-28 · updated 2026-06-17
- Weakness: CWE-636
Description
OpenClaw before 2026.3.31 contains a fail-open vulnerability in the plugin installation flow where security scan failures do not block installation. Attackers can exploit scan failures to install untrusted plugins when operators proceed despite visible scan warnings.
Affected products
- OpenClaw: before 2026.3.31 — fixed in 2026.3.31
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.31. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/0d7f1e2c84eca65df7dee890d9c30e2a841c030a
- https://github.com/openclaw/openclaw/commit/44b993613601280d46a5b88190e46669fc13d669
- https://github.com/openclaw/openclaw/commit/7a953a52271b9188a5fa830739a4366614ff9916
- https://github.com/openclaw/openclaw/commit/bf96c67fd1954740aeabfadc7cfe3098bcfc6b68
- https://github.com/openclaw/openclaw/security/advisories/GHSA-cwq8-6f96-g3q4
- https://www.vulncheck.com/advisories/openclaw-fail-open-security-scan-bypass-in-plugin-installation
Get alerted when CVE-2026-41377 or the next vulnerability affects your stack