What’s Vulnerable › Vulnerabilities
CVE-2026-41386: OpenClaw < 2026.3.22 - Privilege Escalation via Unbound Bootstrap Setup Codes
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-28 · updated 2026-06-17
- Weakness: CWE-648
Description
OpenClaw before 2026.3.22 contains a privilege escalation vulnerability where bootstrap setup codes are not bound to intended device roles and scopes during pairing. Attackers can exploit this during first-use device pairing to escalate privileges beyond their intended role and scope.
Affected products
- OpenClaw: before 2026.3.22 — fixed in 2026.3.22
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.22. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/a600c72ed7d0045a27f58bf031d2b36ecb0141c9
- https://github.com/openclaw/openclaw/security/advisories/GHSA-gg9v-mgcp-v6m7
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-unbound-bootstrap-setup-codes
Get alerted when CVE-2026-41386 or the next vulnerability affects your stack