What’s Vulnerable › Vulnerabilities
CVE-2026-41396: OpenClaw < 2026.3.31 - Environment Variable Override of Plugin Trust Root
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-28 · updated 2026-06-17
- Weakness: CWE-829
Description
OpenClaw before 2026.3.31 allows workspace .env files to override the OPENCLAW_BUNDLED_PLUGINS_DIR environment variable, compromising plugin trust verification. Attackers with control over workspace configuration can inject malicious plugins by overriding the bundled plugin trust root directory.
Affected products
- OpenClaw: before 2026.3.31 — fixed in 2026.3.31
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.31. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/330a9f98cb29c79b1c16a2117e03d6276a0d6289
- https://github.com/openclaw/openclaw/security/advisories/GHSA-qcj9-wwgw-6gm8
- https://www.vulncheck.com/advisories/openclaw-environment-variable-override-of-plugin-trust-root
Get alerted when CVE-2026-41396 or the next vulnerability affects your stack