What’s Vulnerable › Vulnerabilities
CVE-2026-41404: OpenClaw < 2026.3.31 - Operator Admin Privilege Escalation via Trusted-Proxy Authentication
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-28 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw before 2026.3.31 contains an incomplete scope-clearing vulnerability in trusted-proxy authentication mode that allows operator.admin privilege escalation. Attackers can exploit this by declaring operator scopes on non-Control-UI clients, allowing self-declared scopes to persist on identity-bearing authentication paths and escalate privileges.
Affected products
- OpenClaw: before 2026.3.31 — fixed in 2026.3.31
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.31. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/8b88b927cb0747ad24d95b07d35682bf85dc5b0e
- https://github.com/openclaw/openclaw/security/advisories/GHSA-g374-mggx-p6xc
- https://www.vulncheck.com/advisories/openclaw-operator-admin-privilege-escalation-via-trusted-proxy-authentication
Get alerted when CVE-2026-41404 or the next vulnerability affects your stack