What’s Vulnerable › Vulnerabilities
CVE-2026-41416: PJSIP: Asymmetric ptime integer overflow in Media Stream
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-24 · updated 2026-10-26
- Weakness: CWE-190
Description
PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, there is an integer overflow in media stream buffer size calculation when processing SDP with asymmetric ptime configuration. The overflow may result in an undersized buffer allocation, which can lead to unexpected application termination or memory corruption This vulnerability is fixed in 2.17.
Affected products
- teluu pjsip: before 2.17 — fixed in 2.17
How to fix
Upgrade to a fixed version: teluu pjsip 2.17. Check the vendor advisory for mitigations.
References
- https://github.com/pjsip/pjproject/commit/66fe416c96e957417621b7be16e9e587d159f9bb
- https://github.com/pjsip/pjproject/security/advisories/GHSA-f33g-8hjq-62xr
Get alerted when CVE-2026-41416 or the next vulnerability affects your stack