What’s Vulnerable › Vulnerabilities
CVE-2026-41423: Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-06-17
- Weakness: CWE-918
Description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8, a Server-Side Request Forgery (SSRF) vulnerability exists in @angular/platform-server due to improper handling of URLs during Server-Side Rendering (SSR). When an attacker sends a request such as GET /\evil.com/ HTTP/1.1 the server engine (Express, etc.) passes the URL string to Angular’s rendering functions. Because the URL parser normalizes the backslash to a forward slash for HTTP/HTTPS schemes, the internal state of the application is hijacked to believe the current origin is evil.com. This misinterpretation tricks the application into treating the attacker’s domain as the local origin. Consequently, any relative HttpClient requests or PlatformLocation.hostname references are redirected to the attacker controlled server, potentially exposing internal APIs or metadata services. This issue has been patched in versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8.
Affected products
- angular: before 19.2.21; from 20.0.0 before 20.3.19; from 21.0.0 before 21.2.9; 22.0.0-next0, 22.0.0-next1, 22.0.0-next2, 22.0.0-next3, 22.0.0-next4, 22.0.0-next5 (+3) — fixed in 19.2.21, 20.3.19, 21.2.9
How to fix
Upgrade to a fixed version: angular 19.2.21, 20.3.19, 21.2.9. Check the vendor advisory for mitigations.
References
- https://github.com/angular/angular/commit/ede7c58a2aa13fdccc8f0b67ce93ba1c11749412
- https://github.com/angular/angular/pull/68194
- https://github.com/angular/angular/security/advisories/GHSA-45q2-gjvg-7973
Get alerted when CVE-2026-41423 or the next vulnerability affects your stack