What’s Vulnerable › Vulnerabilities
CVE-2026-41427: Better Auth OAuth 2.1 Provider: Unprivileged users can register OAuth clients
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-24 · updated 2026-10-26
- Weakness: CWE-863
Description
Better Auth is an authentication and authorization library for TypeScript. Prior to 1.6.5, the clientPrivileges option documents a create action, but the OAuth client creation endpoints did not invoke the hook before persisting new clients. Deployments that configured clientPrivileges to restrict client registration were not actually restricted — any authenticated user could reach the create endpoints and register an OAuth client with attacker-chosen redirect URIs and metadata. This vulnerability is fixed in 1.6.5.
Affected products
- Better-Auth/Oauth-Provider: from 1.4.9 before 1.6.5; 1.4.8, 1.4.8-beta7, 1.7.0-beta0 — fixed in 1.6.5
How to fix
Upgrade to a fixed version: Better-Auth/Oauth-Provider 1.6.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-41427 or the next vulnerability affects your stack