What’s Vulnerable › Vulnerabilities
CVE-2026-4147: Stack memory disclosure in filemd5 command
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-17 · updated 2026-06-17
- Weakness: CWE-457
Description
An authenticated user with the read role may read limited amounts of uninitialized stack memory via specially-crafted issuances of the filemd5 command.
Affected products
- MongoDB: from 7.0.0 before 7.0.31; from 8.0.0 before 8.0.20; from 8.2.0 before 8.2.6; 8.3.0-alpha0, 8.3.0-alpha1, 8.3.0-alpha2, 8.3.0-alpha3, 8.3.0-rc1 — fixed in 7.0.31, 8.0.20, 8.2.6
How to fix
Upgrade to a fixed version: MongoDB 7.0.31, 8.0.20, 8.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-4147 or the next vulnerability affects your stack