What’s Vulnerable › Vulnerabilities
CVE-2026-41471: Easy PayPal Events & Tickets < 1.4 Information Disclosure via QR Code Endpoint
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-10-26
- Weakness: CWE-639
Description
The Easy PayPal Events & Tickets plugin for WordPress before version 1.4 contains an information disclosure vulnerability in the QR code scanning endpoint that allows unauthenticated attackers to enumerate and retrieve all customer order records. Attackers can iterate over sequential WordPress post IDs through the scan_qr.php endpoint to harvest the complete set of orders stored in the database without requiring authentication or prior knowledge of specific order identifiers.
Affected products
- Scott Paterson easy-paypal-events-tickets: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Scott Paterson easy-paypal-events-tickets 1.4.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/4lec4st/9fd04b4bfadb3f7e388f61588f5f2564
- https://wordpress.org/plugins/easy-paypal-events-tickets/#developers
- https://www.vulncheck.com/advisories/easy-paypal-events-tickets-information-disclosure-via-qr-code-endpoint
Get alerted when CVE-2026-41471 or the next vulnerability affects your stack