What’s Vulnerable › Vulnerabilities
CVE-2026-41472: CyberPanel < 2.4.5 Stored XSS via AI Scanner Dashboard
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-24 · updated 2026-10-26
- Weakness: CWE-79
Description
CyberPanel versions prior to 2.4.5 contain a stored cross-site scripting vulnerability in the AI Scanner dashboard where the POST /api/ai-scanner/callback endpoint lacks authentication and allows unauthenticated attackers to inject malicious JavaScript by overwriting the findings_json field of ScanHistory records. Attackers can inject JavaScript that executes in an administrator's authenticated session when they visit the AI Scanner dashboard, allowing them to issue same-origin requests to plant cron jobs and achieve remote code execution on the server.
Affected products
- usmannasir cyberpanel: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: usmannasir cyberpanel 2.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/usmannasir/cyberpanel/commit/8eb29181cb137baa4adb4bba5dce60f601d55a5f
- https://itsrez.re/post/cyberpanel-rce
- https://www.vulncheck.com/advisories/cyberpanel-stored-xss-via-ai-scanner-dashboard
Get alerted when CVE-2026-41472 or the next vulnerability affects your stack