What’s Vulnerable › Vulnerabilities
CVE-2026-41473: CyberPanel < 2.4.5 Unauthenticated API Access via AI Scanner Endpoints
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-24 · updated 2026-10-26
- Weakness: CWE-306
Description
CyberPanel versions prior to 2.4.5 contain an authentication bypass vulnerability in the AI Scanner worker API endpoints that allows unauthenticated remote attackers to write arbitrary data to the database by sending requests to the /api/ai-scanner/status-webhook and /api/ai-scanner/callback endpoints. Attackers can exploit the lack of authentication checks to cause denial of service through storage exhaustion, corrupt scan history records, and pollute database fields with malicious data.
Affected products
- usmannasir cyberpanel: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: usmannasir cyberpanel 2.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/usmannasir/cyberpanel/commit/8eb29181cb137baa4adb4bba5dce60f601d55a5f
- https://itsrez.re/post/cyberpanel-rce
- https://www.vulncheck.com/advisories/cyberpanel-unauthenticated-api-access-via-ai-scanner-endpoints
Get alerted when CVE-2026-41473 or the next vulnerability affects your stack